Загрузка...
Категории:

Загрузка...

Конспект урока (11 класс) Тема урока: Основные типы алгоритмических структур

Загрузка...
Поиск по сайту:


Скачать 40.57 Kb.
Дата08.05.2012
Размер40.57 Kb.
ТипУрок
Содержание
3. Знакомство с новым материалом.
2. Алгоритмическая структура "ветвление"
2. Алгоритмическая структура "выбор"
2. Алгоритмическая структура "цикл"
Подобный материал:

Конспект урока (11 класс)

Тема урока: Основные типы алгоритмических структур.

Цели урока: познакомиться с основными типами алгоритмических структур (линейный алгоритм, ветвление, выбор, цикл).

План урока:

1. Орг. момент.

2. Актуализация знаний.

3. Знакомство с новым материалом.

4. Подведение итога урока.


1. Орг. момент.

Приветствие, постановка цели урока.

2. Актуализация знаний.

Устный опрос:

    1. Что такое алгоритм? (понятное и точное предписание исполнителю совершить последовательность действий, направленных на решение поставленной задачи или цели)

    2. В расчете на кого должен строиться алгоритм? (в расчете на конкретного исполнителя)

    3. Что такое формальное исполнение алгоритма? (автоматическое исполнение алгоритма)

    4. Какие способы задания алгоритма существуют? (словесный, графический, алгоритмический язык, программный)

    5. Представьте алгоритм вычисления площади треугольника по формуле Герона графическим способом?

    6. Вычислим значение алгоритма. Даны значения a=3, b=5, что будет получено в результате выполнения алгоритма?

      1. A=1 b) A=1 c) A=1 d)

B=2 B=2 B=2

A=A+B C=A A=A+B

B=2*B A=B B=A–B

B=C A=A–B


^ 3. Знакомство с новым материалом.

  1. Линейный алгоритм – алгоритм, в котором команды

выполняются последовательно одна за другой.

Школьный алгоритмический язык

Язык блок-схем

действие 1
действие 2
. . . . . . . . .
действие n





^ 2. Алгоритмическая структура "ветвление".

Та или иная серия команд выполняется в зависимости от результата проверки условия (да или нет). Каждый из путей ведет к общему выходу, так что работа алгоритма будет продолжаться независимо от того, какой путь будет выбран.

    Школьный алгоритмический язык    

Язык блок-схем

1. если—то

если условие

  то действия

все



2. если—то—иначе

если условие

  то действия 1

  иначе действия 2

все



Примеры структуры ветвление

Школьный алгоритмический язык

Язык блок-схем

если x > 0

  то y := sin(x)

все



если a > b

  то a := 2*a; b := 1

  иначе b := 2*b

все




^ 2. Алгоритмическая структура "выбор".

В алгоритмической структуре «выбор» выполняется одна из нескольких последовательностей команд при истинности соответствующего условия.


1. выбор

выбор

  при условие 1: действия 1

  при условие 2: действия 2

  . . . . . . . . . . . .

  при условие N: действия N

все



2. выбор—иначе

выбор

  при условие 1: действия 1

  при условие 2: действия 2

  . . . . . . . . . . . .

  при условие N: действия N

  иначе действия N+1

все



Примеры структуры выбор

выбор

  при n = 1: y := sin(x)

  при n = 2: y := cos(x)

  при n = 3: y := 0

все



выбор

  при a > 5: i := i+1

  при a = 0: j := j+1

  иначе i := 10; j:=0

все




 


^ 2. Алгоритмическая структура "цикл".

Обеспечивает многократное выполнение некоторой совокупности действий, которая называется телом цикла. Основные разновидности циклов представлены в таблице:

Школьный алгоритмический язык

Язык блок-схем

Цикл типа пока.
Предписывает выполнять тело цикла до тех пор,
пока выполняется условие, записанное после слова пока.

нц пока условие

  тело цикла

  (последовательность действий)

кц



Цикл типа для.
Предписывает выполнять тело цикла для всех значений
      некоторой переменной (параметра цикла) в заданном диапазоне.     

нц для i от i1 до i2

  тело цикла

  (последовательность действий)

кц



Примеры структуры цикл

       Школьный алгоритмический язык      

           Язык блок-схем            

нц пока i <= 5

  S := S+A[i]

  i := i+1

кц



нц для i от 1 до 5

  X[i] := i*i*i

  Y[i] := X[i]/2

кц




 
 






Скачать, 56.94kb.
Поиск по сайту:

Добавить текст на свой сайт
Загрузка...


База данных защищена авторским правом ©ДуГендокс 2000-2014
При копировании материала укажите ссылку
наши контакты
DoGendocs.ru
Рейтинг@Mail.ru